Friday, 25 March 2011

Note :- Angry Birds requires OpenGL 1.3 or later to run. Devices that do not support OpenGL 1.3 are not supported.

Download Angry Birds For PC

0comments:

Post a comment